Table of Contents
Challenge
After maintenance to upgrade to a new release of Veeam Backup for Microsoft 365, backup of Exchange Online data may fail with “Unauthorized (401)” error.
The issue affects organizations using Modern authentication and legacy protocols with an application secret.
Cause
In recent releases, Veeam Backup for Microsoft 365 has switched to the SOAP Autodiscover service for resolving users during Exchange backup. To use this API, the application used for the organization’s backup must be assigned the full_access_as_app permission.
Solution
To add the "full_access_as_app" permission to your Azure AD app registration, do the following:
- Sign in to the Azure portal
- Go to Entra ID > App registrations and select your application.
- Select API permissions > Add a permission > APIs my organization uses
- Select Office 365 Exchange Online API in the list, go to the Application permissions tab, and select the "full_access_as_app" permission.